How to Configure Your PowerSchool App

Each school or district maintains their own PowerSchool environment. In order for the PowerSchool apps to work properly, your school or district must:

  • Be running version 7.2.3 or higher of PowerSchool
  • Registered with PowerSource
  • Have Single-sign On (SSO) active for parent accounts
  • Have mobile services enabled